<!DOCTYPE HTML>
<html class="no-js" lang="en">
<head>
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.promotionandarts.org/sites/default/themes/bopa/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="Mayor Catherine E. Pugh and the Baltimore Office of Promotion &amp; The Arts celebrates the 19th annual Dr. Martin Luther King, Jr. Parade. The parade commemorates the life of civil rights leader and icon Dr. Martin Luther King, Jr. on Monday, January 21, 2019 at noon. More than 70 groups participate in the parade including high school and community bands, honor/color guards," />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="http://www.promotionandarts.org/events-festivals/19th-annual-dr-martin-luther-king-jr-parade" />
<link rel="shortlink" href="http://www.promotionandarts.org/node/131" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	<link rel="shortcut icon" href="sites/default/themes/bopa/favicon.ico">
	<link rel="apple-touch-icon" href="sites/default/themes/bopa/apple-touch-icon.png">

	<title>19th Annual Dr. Martin Luther King, Jr. Parade | Baltimore Office of Promotion & the Arts</title>

	<link type="text/css" rel="stylesheet" href="http://www.promotionandarts.org/sites/default/themes/bopa/assets/css/main.css?piwzzh" media="screen" />

	<script type="text/javascript">window.theme_path = '/sites/default/themes/bopa';</script>

	
	<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>

	<!--[if lte IE 9]>
	<script src="/sites/default/themes/bopa/assets/js/vendor/jquery.placeholder.min.js"></script>
	<script>jQuery(function($) { $('input, textarea').placeholder(); });</script>
	<style>.placeholder { color: #aaa; }</style>
	<![endif]-->

	<!--[if lte IE 8]>
	<script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
	<script src="/sites/default/themes/bopa/assets/js/vendor/selectivizr-1.0.3.js"></script>
	<script src="/sites/default/themes/bopa/assets/js/vendor/respond.min.js"></script>
	<![endif]-->

	<link type="text/css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto+Condensed" media="screen" />
	<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-37473981-2', 'auto');
  ga('send', 'pageview');

</script>
</head>

<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-131 node-type-detail-page" >

	<div id="fb-root"></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=1403245116616627";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="l-wrapper">

	<header class="l-header">
	<div class="l-header--inner">
		<a href="/">
			<img class="l-logo" src="http://www.promotionandarts.org/sites/default/files/bopa_logo_new.png" alt="Baltimore Office of Promotion &amp; The Arts" />
		</a>
		<p class="l-tagline">Baltimore’s arts council, event center and film office. A nonprofit 501(c)(3) organization.</p>
		<p class="is-hidden"><a href="#content">Skip to main content</a></p>
	
		<nav class="l-nav">
			<div class="l-nav--main">
					<ul class="m-nav_main"><li><a href="/about-us">About Us</a><ul class="m-nav_main_subnav"><li><a href="/about-us/bopa-board-directors">Board of Directors</a></li>
<li><a href="/about-us/business-opportunities">Business Opportunities</a></li>
<li><a href="/about-us/contact-us">Contact Us</a></li>
<li><a href="/about-us/jobs">Jobs</a></li>
<li><a href="/about-us/press-room">Press Room</a></li>
<li><a href="/about-us/bopa-newsletters">BOPA Newsletters</a></li>
<li><a href="/about-us/ceo-announcement">CEO Announcement</a></li>
<li><a href="/get-involved/volunteer" title="">Volunteer</a></li>
</ul></li>
<li><a href="/events-festivals" class="active-trail">Events &amp; Festivals</a><ul class="m-nav_main_subnav"><li><a href="/events-festivals/19th-annual-dr-martin-luther-king-jr-parade" class="active-trail active">19th Annual Dr. Martin Luther King, Jr. Parade</a></li>
<li><a href="/events-festivals/911-memorial-maryland-exhibit">9/11 Memorial of Maryland Exhibit</a></li>
<li><a href="/events-festivals/annual-downtown-partnership-monument-lighting">Annual Downtown Partnership Monument Lighting</a></li>
<li><a href="/events-festivals/artscape">Artscape</a></li>
<li><a href="/events-festivals/baltimore-book-festival">Baltimore Book Festival</a></li>
<li><a href="/events-festivals/ports-america-chesapeake-4th-july-celebration">Ports America Chesapeake 4th of July Celebration</a></li>
<li><a href="/events-festivals/baltimore-farmers-market-bazaar">Baltimore Farmers&#039; Market &amp; Bazaar</a></li>
<li><a href="/events-festivals/baltimore-running-festival">Baltimore Running Festival</a></li>
<li><a href="/events-festivals/bromo-seltzer-arts-tower-open-house">Bromo Seltzer Arts Tower Open House</a></li>
<li><a href="/culture-fly">Culture Fly</a></li>
<li><a href="/events-festivals/light-city">Light City</a></li>
<li><a href="/events-festivals/light-city-image-gallery">Light City Image Gallery</a></li>
<li><a href="/events-festivals/new-years-eve-spectacular">New Year&#039;s Eve Spectacular</a></li>
<li><a href="/events-festivals/picnic-top-world">Picnic at the Top of the World</a></li>
<li><a href="/sobo-summer-music-series">SoBo Summer Music Series</a></li>
<li><a href="/events-festivals/30th-annual-open-studio-tour">30th Annual Open Studio Tour</a></li>
<li><a href="/events-festivals/holiday-bazaar-tea-cloisters">Holiday Bazaar &amp; Tea @ The Cloisters</a></li>
<li><a href="/events-festivals/sound-live-presented-hard-rock-cafe-baltimore">Sound Off Live! presented by Hard Rock Cafe Baltimore</a></li>
</ul></li>
<li><a href="/arts-council">Arts Council</a><ul class="m-nav_main_subnav"><li><a href="/arts-council/penn-north-metro-artist-selection">Penn-North Metro Artist Selection</a></li>
<li><a href="/arts-council/public-art">Public Art</a></li>
<li><a href="/arts-council/art-work">Art @ Work</a></li>
<li><a href="/arts-council/baltimore-arts-blog">Baltimore Arts Blog</a></li>
<li><a href="/arts-council/baltimore-mural-program">Baltimore Mural Program</a></li>
<li><a href="/arts-council/baltimore-arts-entertainment-districts">Baltimore Arts &amp; Entertainment Districts</a></li>
<li><a href="/arts-council/bright-starts-program">Bright StARTS Program</a></li>
<li><a href="/arts-council/bromo-seltzer-arts-tower">Bromo Seltzer Arts Tower</a></li>
<li><a href="/arts-council/free-fall-baltimore">Free Fall Baltimore</a></li>
<li><a href="/arts-council/janet-walter-sondheim-artscape-prize">Janet &amp; Walter Sondheim Artscape Prize</a></li>
<li><a href="/arts-council/baltimore-public-art-commission">Public Art Commission</a></li>
<li><a href="/arts-council/school-33-art-center">School 33 Art Center</a></li>
<li><a href="/arts-council/transit-project">Transit Project</a></li>
<li><a href="/arts-council/arts-economic-prosperity-report">Arts &amp; Economic Prosperity Report</a></li>
<li><a href="/arts-council/bopa-youth-arts-council">BOPA Youth Arts Council</a></li>
<li><a href="/arts-council/calls-artists">Calls for Artists</a></li>
<li><a href="/arts-council/municipal-art-society-baltimore-city-artist-travel-prize">Municipal Art Society of Baltimore City Artist Travel Prize</a></li>
</ul></li>
<li><a href="/landmarks-galleries">Landmarks &amp; Galleries</a><ul class="m-nav_main_subnav"><li><a href="/landmarks-galleries/bromo-seltzer-arts-tower-0">Bromo Seltzer Arts Tower</a></li>
<li><a href="/landmarks-galleries/cloisters-castle">Cloisters Castle</a></li>
<li><a href="/landmarks-galleries/school-33-art-center">School 33 Art Center</a></li>
<li><a href="/landmarks-galleries/top-world-observation-level">Top of the World Observation Level</a></li>
</ul></li>
<li><a href="http://baltimorefilm.com" title="">Film Office</a></li>
<li><a href="/grants">Grants</a><ul class="m-nav_main_subnav"><li><a href="/grants/creative-baltimore-fund">Creative Baltimore Fund</a></li>
<li><a href="/grants/lots-alive">LOTS ALIVE</a></li>
<li><a href="/grants/mecu-neighborhood-event-grants">MECU Neighborhood Event Grants</a></li>
<li><a href="/grants/community-art-grants">Community Art Grants</a></li>
</ul></li>
<li><a href="/sponsorships">Sponsorships</a><ul class="m-nav_main_subnav"><li><a href="/sponsorships/sponsoring-artscape">Artscape</a></li>
<li><a href="/sponsorships/sponsoring-baltimore-book-festival">Baltimore Book Festival</a></li>
<li><a href="/sponsorships/sponsoring-baltimore-farmers-market-bazaar">Baltimore Farmers&#039; Market &amp; Bazaar</a></li>
<li><a href="/sponsorships/sponsoring-baltimore%E2%80%99s-4th-july-celebration-presented-ports-america-chesapeake">Baltimore’s 4th of July Celebration presented by Ports America Chesapeake</a></li>
<li><a href="/sponsorships/sponsoring-new-year%E2%80%99s-eve-spectacular">New Year’s Eve Spectacular</a></li>
<li><a href="/sponsorships/permits-product-promotions-sampling">Permits for Product Promotions &amp; Sampling</a></li>
<li><a href="/sponsorships/light-city">Light City</a></li>
</ul></li>
<li><a href="/get-involved">Get Involved</a><ul class="m-nav_main_subnav"><li><a href="/get-involved/donate">Donate</a></li>
<li><a href="http://promotionandarts.org/sponsorships" title="">Sponsorships</a></li>
<li><a href="/get-involved/volunteer">Volunteer</a></li>
</ul></li>
</ul>			</div>

			<div class="l-nav--utility">
				<ul class="m-nav_utility">
					<li><a href="/get-involved/donate" class="alt"><i class="icon-donate"></i> Donate</a></li>
					<li><a href="#newsletter-signup" class="fancybox"><i class="icon-email"></i>Join our Email</a></li>
					<li><a href="/about-us/contact-us"><i class="icon-contact"></i>Contact</a></li>
					<li><a href="http://www.baltimorearts.org"><i class="icon-blog"></i>Arts Blog</a></li>
				</ul>
			</div>

			<div class="l-nav--search">
				<form class="m-search" action="/search/node">
					<fieldset>
                        <legend class="is-hidden">Search this site</legend>
						<label for="keyword">Search</label>
						<input type="search" id="keyword" name="keys" placeholder="Search" />
					</fieldset>
				</form>
			</div>
		</nav><!--/l-nav -->

	</div><!--/l-header inner -->
</header><!--/l-header -->	
	<div class="l-main">
		
				
		<div class="l-container">
			<div class="l-row">
				<p class="is-hidden">You are here:</p>
<ul class="m-breadcrumbs clearfix"><li class="breadcrumb-0 first"><a href="/">Home</a></li><li class="breadcrumb-1"><a href="/events-festivals">Events &amp; Festivals</a></li><li class="breadcrumb-2 last"> 19th Annual Dr. Martin Luther King, Jr. Parade</li></ul>

<div class="tabs"></div>

<h1>19th Annual Dr. Martin Luther King, Jr. Parade</h1>


									
						
									<p>
				<time datetime="2019-01-21T12:00:00Z">
					<span class="date-display-single">Monday, January 21, 2019 - <span class="date-display-range"><span class="date-display-start" property="dc:date" datatype="xsd:dateTime" content="2019-01-21T12:00:00-05:00">12:00pm</span> to <span class="date-display-end" property="dc:date" datatype="xsd:dateTime" content="2019-01-21T14:00:00-05:00">2:00pm</span></span></span>									</time>
			</p>
						
						<div class="l-event--media">
				<div class="flexslider">
					<ul class="slides">
		
						<li><img src="http://www.promotionandarts.org/sites/default/files/styles/slider/public/MLK%20Day%20Parade%201_0.jpg?itok=qRvE8J2Q" alt="" /></li><li><img src="http://www.promotionandarts.org/sites/default/files/styles/slider/public/MLK%20Day%20Parade%202.jpg?itok=pm-tgM7E" alt="" /></li><li><img src="http://www.promotionandarts.org/sites/default/files/styles/slider/public/MLK%20Day%20Parade%204.jpg?itok=qZKvXo2j" alt="" /></li><li><img src="http://www.promotionandarts.org/sites/default/files/styles/slider/public/MLK%20Day%20Parade%205.jpg?itok=f_4eEMBS" alt="" /></li>		
					</ul>
				</div><!--/flexslider -->
			</div><!--/event media -->
						
									
												<p class="l-event--countdown">
				<strong>38</strong> days until the event
			</p>
						
						<div class="l-event--detail">
				<p><strong>Mayor Catherine E. Pugh</strong> and the <strong>Baltimore Office of Promotion &amp; The Arts</strong> celebrates the <strong>19th annual Dr. Martin Luther King, Jr. Parade</strong>. The parade commemorates the life of civil rights leader and icon Dr. Martin Luther King, Jr. on <strong>Monday, January 21, </strong><strong>2019</strong><strong>&nbsp;at noon</strong>. More than 70 groups participate in the parade including high school and community bands, honor/color guards, equestrian units, fraternities &amp; sororities, lively dance squads and civic organizations. The parade steps off at the intersection of <strong>Martin Luther King, Jr. Boulevard and Eutaw Street,&nbsp;</strong>proceeds south on Martin Luther King, Jr. Boulevard and disbands at Baltimore Street. Spectators are invited to view the parade from along the route or near the reviewing stand at <strong>Martin Luther King, Jr. Boulevard and Franklin Street</strong>.<br /><br /><strong><u>2019 Parade Application</u></strong></p><p>The&nbsp;<strong>Baltimore Office of Promotion &amp; The Arts (BOPA)&nbsp;</strong>is now accepting applications for the 19th annual Dr. Martin Luther King, Jr. Parade. Groups and organizations that resonate with Dr. King&rsquo;s legacy are encouraged to apply for the opportunity.</p><p><strong>Deadline for submissions:</strong><br />Monday, December 31, 2018<br /><br /><strong><a href="https://promotionandarts.submittable.com/submit/125278/dr-martin-luther-king-jr-2019-parade-application">Click here</a> to apply.</strong></p><p>If you are a for-profit organization, institute or business, please contact&nbsp;<a href="mailto:bsicard@promotionandarts.org">Bob Sicard</a>&nbsp;for parade sponsorship/involvement opportunities at (410) 752-8632.</p><p><strong>PLEASE NOTE: Submission of this application does not guarantee acceptance. Past participants are not guaranteed acceptance in the 2019 parade. Late applications will not be accepted.</strong></p>			</div>
			
		</div><!--/row -->
	</div><!--/container -->

	
		<div class="l-container">
		<div class="l-row">
						<h2 class="alt">Sponsored By:</h2>
			
						
	
						<a href="http://lexingtonmarket.com/">
							<img src="http://www.promotionandarts.org/sites/default/files/styles/sponsor_logo/public/LexingtonMarket.png?itok=-4dEXOTZ" alt="">
						</a>
	
								
					
					</div><!--/row -->
	</div><!--/l-container -->
			
			
	</div><!--/l-main -->

	<footer class="l-footer">
  <div class="l-container">

    <div class="l-row">

      <div class="l-footer--info">
        	<p>Baltimore Office of Promotion &amp; The Arts | 10 E. Baltimore Street, 10th Floor, Baltimore, MD 21202 | 410-752-8632 | ©2016</p>
      </div>

      <div class="l-footer--social">
        <a href="http://www.linkedin.com/company/baltimore-office-of-promotion-&amp;-the-arts"><img src="/sites/default/themes/bopa/assets/images/linkedin.png" alt="Linked In" /></a>
        <a href="http://www.facebook.com/promoandarts"><img src="/sites/default/themes/bopa/assets/images/facebook.png" alt="Facebook" /></a>
        <a href="https://twitter.com/promoandarts"><img src="/sites/default/themes/bopa/assets/images/twitter.png" alt="Twitter" /></a>
        <a href="http://www.youtube.com/user/BOPAInc"><img src="/sites/default/themes/bopa/assets/images/youtube.png" alt="YouTube" /></a>
        <a href="https://www.instagram.com/promoandarts/"><img src="/sites/default/themes/bopa/assets/images/instagram.png" alt="Instagram" /></a>
      </div>

    </div>

    <div id="newsletter-signup">
      <!--Begin CTCT Sign-Up Form-->
      <!-- EFD 1.0.0 [Fri Sep 09 15:47:44 EDT 2016] -->
      <link rel='stylesheet' type='text/css' href='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/css/signup-form.css'>
      <div class="ctct-embed-signup" style="font: 16px Helvetica Neue, Arial, sans-serif; font: 1rem Helvetica Neue, Arial, sans-serif; line-height: 1.5; -webkit-font-smoothing: antialiased;">
         <div style="color:#800000; background-color:#fff; border-radius:5px;">
             <span id="success_message" style="display:none;">
                 <div style="text-align:center;">Thanks for signing up!</div>
             </span>
             <form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">
                 <h2 style="margin:0;">Sign up to stay in touch with the Baltimore Office of Promotion &amp; The Arts!</h2>
                 <p>Sign up to get interesting news and updates delivered to your inbox.</p>
                 <!-- The following code must be included to ensure your sign-up form works properly. -->
                 <input data-id="ca:input" type="hidden" name="ca" value="1b7a6767-1236-42c5-b88e-e546d1edba00">
                 <input data-id="list:input" type="hidden" name="list" value="1958764199">
                 <input data-id="source:input" type="hidden" name="source" value="EFD">
                 <input data-id="required:input" type="hidden" name="required" value="list,email,first_name,last_name">
                 <input data-id="url:input" type="hidden" name="url" value="">
                 <p data-id="Email Address:p" ><label data-id="Email Address:label" data-name="email" class="ctct-form-required">Email Address</label> <input data-id="Email Address:input" type="text" name="email" value="" maxlength="80"></p>
                 <p data-id="First Name:p" ><label data-id="First Name:label" data-name="first_name" class="ctct-form-required">First Name</label> <input data-id="First Name:input" type="text" name="first_name" value="" maxlength="50"></p>
                 <p data-id="Last Name:p" ><label data-id="Last Name:label" data-name="last_name" class="ctct-form-required">Last Name</label> <input data-id="Last Name:input" type="text" name="last_name" value="" maxlength="50"></p>
                 <button type="submit" class="Button ctct-button Button--block Button-secondary" data-enabled="enabled">Sign Up</button>
                      <div><p class="ctct-form-footer">By submitting this form, you are granting: Baltimore Office of Promotion &amp; The Arts, 10 E. Baltimore Street, Baltimore, Maryland, 21202, United States, http://promotionandarts.org/ permission to email you. You may unsubscribe via the link found at the bottom of every email.  (See our <a href="http://www.constantcontact.com/legal/privacy-statement" target="_blank">Email Privacy Policy</a> for details.) Emails are serviced by Constant Contact.</p></div>
             </form>
         </div>
      </div>
      <script type='text/javascript'>
         var localizedErrMap = {};
         localizedErrMap['required'] =                  'This field is required.';
         localizedErrMap['ca'] =                                               'An unexpected error occurred while attempting to send email.';
         localizedErrMap['email'] =                                         'Please enter your email address in name@email.com format.';
         localizedErrMap['birthday'] =                   'Please enter birthday in MM/DD format.';
         localizedErrMap['anniversary'] =            'Please enter anniversary in MM/DD/YYYY format.';
         localizedErrMap['custom_date'] =         'Please enter this date in MM/DD/YYYY format.';
         localizedErrMap['list'] =                                              'Please select at least one email list.';
         localizedErrMap['generic'] =                     'This field is invalid.';
         localizedErrMap['shared'] =                      'Sorry, we could not complete your sign-up. Please contact us to resolve this.';
         localizedErrMap['state_mismatch'] = 'Mismatched State/Province and Country.';
                      localizedErrMap['state_province'] = 'Select a state/province';
         localizedErrMap['selectcountry'] =        'Select a country';
         var postURL = 'https://visitor2.constantcontact.com/api/signup';
      </script>
      <script type='text/javascript' src='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/js/signup-form.js'></script>
      <!--End CTCT Sign-Up Form-->
    </div>

  </div>
</footer>

</div> <!-- /.l-wrapper -->
	<!-- Page bottom -->
	<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/handlebars.js/2.0.0-alpha.2/handlebars.runtime.min.js"></script>
<script type="text/javascript" src="http://www.promotionandarts.org/sites/default/themes/bopa/assets/fancybox/jquery.fancybox.js?piwzzh"></script>
<script type="text/javascript" src="http://www.promotionandarts.org/sites/default/themes/bopa/assets/js/build/run.js?piwzzh"></script>
	<!-- end bottom -->

</body>
</html>
